using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^.\n]+\.[a-z]{2,63}$";
string input = @"EXAMPLE.COM
EXAMPLE.ORG.
EXAMPLE.ORG>.
EXAMPLE.COM""
EXAMPLE.COM"".
EXAMPLE.COM).
EXAMPLE.COM(COMMENT)""
DEPT.EXAMPLE.COM
EXAMPLE.ORG
EXAMPLE.COM";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}