import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^.\\n]+\\.[a-z]{2,63}$";
final String string = "EXAMPLE.COM\n"
+ "EXAMPLE.ORG.\n"
+ "EXAMPLE.ORG>.\n"
+ "EXAMPLE.COM\"\n"
+ "EXAMPLE.COM\".\n"
+ "EXAMPLE.COM).\n"
+ "EXAMPLE.COM(COMMENT)\"\n"
+ "DEPT.EXAMPLE.COM\n"
+ "EXAMPLE.ORG\n"
+ "EXAMPLE.COM";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}