#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^[^BGIJLMORSU\W]{1}[0-9]{1}[0-9W]{1}[ \-]?(?:[0-9]|[^BGIJLMORSU\W]{4})$)"
Local $sString = "D24 FT12" & @CRLF & _
"D22 TF12" & @CRLF & _
"D24 TF13" & @CRLF & _
"A65 TF12" & @CRLF & _
"B32 AC21" & @CRLF & _
"D21 3333" & @CRLF & _
"D6W 3333" & @CRLF & _
"D21 B342" & @CRLF & _
"" & @CRLF & _
"A21 .345" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")