import Foundation
let pattern = #"(^[^BGIJLMORSU\W]{1}[0-9]{1}[0-9W]{1}[ \-]?(?:[0-9]|[^BGIJLMORSU\W]{4})$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
D24 FT12
D22 TF12
D24 TF13
A65 TF12
B32 AC21
D21 3333
D6W 3333
D21 B342
A21 .345
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)