import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^[^BGIJLMORSU\\W]{1}[0-9]{1}[0-9W]{1}[ \\-]?(?:[0-9]|[^BGIJLMORSU\\W]{4})$)";
final String string = "D24 FT12\n"
+ "D22 TF12\n"
+ "D24 TF13\n"
+ "A65 TF12\n"
+ "B32 AC21\n"
+ "D21 3333\n"
+ "D6W 3333\n"
+ "D21 B342\n\n"
+ "A21 .345\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}