use strict;
my $str = 'D24 FT12
D22 TF12
D24 TF13
A65 TF12
B32 AC21
D21 3333
D6W 3333
D21 B342
A21 .345
';
my $regex = qr/(^[^BGIJLMORSU\W]{1}[0-9]{1}[0-9W]{1}[ \-]?(?:[0-9]|[^BGIJLMORSU\W]{4})$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}