$re = '/(^[^BGIJLMORSU\W]{1}[0-9]{1}[0-9W]{1}[ \-]?(?:[0-9]|[^BGIJLMORSU\W]{4})$)/m';
$str = 'D24 FT12
D22 TF12
D24 TF13
A65 TF12
B32 AC21
D21 3333
D6W 3333
D21 B342
A21 .345
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);