// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(^[^BGIJLMORSU\W]{1}[0-9]{1}[0-9W]{1}[ \-]?(?:[0-9]|[^BGIJLMORSU\W]{4})$)").unwrap();
let string = "D24 FT12
D22 TF12
D24 TF13
A65 TF12
B32 AC21
D21 3333
D6W 3333
D21 B342
A21 .345
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}