# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:፻|(?<!፻|^)\G)(?=.*፻)(\h*)([^\s፻]+)(?:(\h*)፻)?/$1፻$2$3/gm;t' <<< "፻this test works፻
፻this test will now work፻
፻simple፻
this is an ፻ extra far more challenging ፻ case with more ፻ than just one match ፻ and even some ፻interleaved whitespace፻, behold!"