#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?:፻|(?<!፻|^)\G)(?=.*፻)(\h*)([^\s፻]+)(?:(\h*)፻)?"
Local $sString = "፻this test works፻" & @CRLF & _
"፻this test will now work፻" & @CRLF & _
"" & @CRLF & _
"፻simple፻" & @CRLF & _
"" & @CRLF & _
"this is an ፻ extra far more challenging ፻ case with more ፻ than just one match ፻ and even some ፻interleaved whitespace፻, behold!"
Local $sSubst = "$1፻$2$3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)