const regex = /(?:፻|(?<!፻|^)\G)(?=.*፻)(\h*)([^\s፻]+)(?:(\h*)፻)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:፻|(?<!፻|^)\\G)(?=.*፻)(\\h*)([^\\s፻]+)(?:(\\h*)፻)?', 'gm')
const str = `፻this test works፻
፻this test will now work፻
፻simple፻
this is an ፻ extra far more challenging ፻ case with more ፻ than just one match ፻ and even some ፻interleaved whitespace፻, behold!`;
const subst = `$1፻$2$3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);