import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:፻|(?<!፻|^)\\G)(?=.*፻)(\\h*)([^\\s፻]+)(?:(\\h*)፻)?";
final String string = "፻this test works፻\n"
+ "፻this test will now work፻\n\n"
+ "፻simple፻\n\n"
+ "this is an ፻ extra far more challenging ፻ case with more ፻ than just one match ፻ and even some ፻interleaved whitespace፻, behold!";
final String subst = "$1፻$2$3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}