use strict;
my $str = '፻this test works፻
፻this test will now work፻
፻simple፻
this is an ፻ extra far more challenging ፻ case with more ፻ than just one match ፻ and even some ፻interleaved whitespace፻, behold!';
my $regex = qr/(?:፻|(?<!፻|^)\G)(?=.*፻)(\h*)([^\s፻]+)(?:(\h*)፻)?/mp;
my $subst = '$1፻$2$3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";