#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:.+?;){2}#(.+?),#"
Local $sString = "1;#FirstName,, Surname,#Domain\Account,#email.@company.com,#email@company.com,#FirstName,, Surname25;#FirstName,, Surname,#Domain\Account,#email.@company.com,#email@company.com,#FirstName,, Surname26;#Helpdesk,#DE\helpdesk,#helpdesk@vega.com,#,#Helpdesk30;#..."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")