import Foundation
let pattern = ##"(?:.+?;){2}#(.+?),#"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"1;#FirstName,, Surname,#Domain\Account,#email.@company.com,#email@company.com,#FirstName,, Surname25;#FirstName,, Surname,#Domain\Account,#email.@company.com,#email@company.com,#FirstName,, Surname26;#Helpdesk,#DE\helpdesk,#helpdesk@vega.com,#,#Helpdesk30;#..."##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}