package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:.+?;){2}#(.+?),#`)
var str = `1;#FirstName,, Surname,#Domain\Account,#email.@company.com,#email@company.com,#FirstName,, Surname25;#FirstName,, Surname,#Domain\Account,#email.@company.com,#email@company.com,#FirstName,, Surname26;#Helpdesk,#DE\helpdesk,#helpdesk@vega.com,#,#Helpdesk30;#...`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}