// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:.+?;){2}#(.+?),#").unwrap();
let string = "1;#FirstName,, Surname,#Domain\\Account,#email.@company.com,#email@company.com,#FirstName,, Surname25;#FirstName,, Surname,#Domain\\Account,#email.@company.com,#email@company.com,#FirstName,, Surname26;#Helpdesk,#DE\\helpdesk,#helpdesk@vega.com,#,#Helpdesk30;#...";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}