$re = '/(?:.+?;){2}#(.+?),#/';
$str = '1;#FirstName,, Surname,#Domain\\Account,#email.@company.com,#email@company.com,#FirstName,, Surname25;#FirstName,, Surname,#Domain\\Account,#email.@company.com,#email@company.com,#FirstName,, Surname26;#Helpdesk,#DE\\helpdesk,#helpdesk@vega.com,#,#Helpdesk30;#...';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);