re = /(?:.+?;){2}#(.+?),#/
str = '1;#FirstName,, Surname,#Domain\\Account,#email.@company.com,#email@company.com,#FirstName,, Surname25;#FirstName,, Surname,#Domain\\Account,#email.@company.com,#email@company.com,#FirstName,, Surname26;#Helpdesk,#DE\\helpdesk,#helpdesk@vega.com,#,#Helpdesk30;#...'
# Print the match result
str.match(re) do |match|
puts match.to_s
end