#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\\doc(.*?)\\in"
Local $sString = "\doc doc1,doc2" & @CRLF & _
"\doc doc1,doc2 \in filed1,field2" & @CRLF & _
"\doc doc1,doc2 \in filed1,field2 \doc doc3,doc4 \in field3,field4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")