$re = '/\\\\doc(.*?)\\\\in/';
$str = '\\doc doc1,doc2
\\doc doc1,doc2 \\in filed1,field2
\\doc doc1,doc2 \\in filed1,field2 \\doc doc3,doc4 \\in field3,field4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);