re = /\\doc(.*?)\\in/
str = '\\doc doc1,doc2
\\doc doc1,doc2 \\in filed1,field2
\\doc doc1,doc2 \\in filed1,field2 \\doc doc3,doc4 \\in field3,field4'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end