const regex = /\\doc(.*?)\\in/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\\doc(.*?)\\\\in', 'g')
const str = `\\doc doc1,doc2
\\doc doc1,doc2 \\in filed1,field2
\\doc doc1,doc2 \\in filed1,field2 \\doc doc3,doc4 \\in field3,field4`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}