package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\\doc(.*?)\\in`)
var str = `\doc doc1,doc2
\doc doc1,doc2 \in filed1,field2
\doc doc1,doc2 \in filed1,field2 \doc doc3,doc4 \in field3,field4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}