package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<img [^>]*\.jg"[^>]*>`)
var str = `<img width="770" alt="5.jg" c="/unload/medialiy/ty6/5.jg" height="499" title=5.jg">
<img width="770" alt="5.jg" c="/unload/medialiy/ty6/5.jg" title=5.jg" height="499">
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}