re = /<img [^>]*\.jg"[^>]*>/
str = '<img width="770" alt="5.jg" c="/unload/medialiy/ty6/5.jg" height="499" title=5.jg">
<img width="770" alt="5.jg" c="/unload/medialiy/ty6/5.jg" title=5.jg" height="499">
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end