// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<img [^>]*\.jg"[^>]*>"#).unwrap();
let string = "<img width=\"770\" alt=\"5.jg\" c=\"/unload/medialiy/ty6/5.jg\" height=\"499\" title=5.jg\">
<img width=\"770\" alt=\"5.jg\" c=\"/unload/medialiy/ty6/5.jg\" title=5.jg\" height=\"499\">
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}