use strict;
my $str = '<img width="770" alt="5.jg" c="/unload/medialiy/ty6/5.jg" height="499" title=5.jg">
<img width="770" alt="5.jg" c="/unload/medialiy/ty6/5.jg" title=5.jg" height="499">
';
my $regex = qr/<img [^>]*\.jg"[^>]*>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}