const regex = /<img [^>]*\.jg"[^>]*>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<img [^>]*\\.jg"[^>]*>', 'g')
const str = `<img width="770" alt="5.jg" c="/unload/medialiy/ty6/5.jg" height="499" title=5.jg">
<img width="770" alt="5.jg" c="/unload/medialiy/ty6/5.jg" title=5.jg" height="499">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}