#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=^#_MIST_#_)(?P<series>[^-]+)(?=\s-)"
Local $sString = "#_MIST_#_... Cartoons - 02 - Dieven Cartoons.cbr" & @CRLF & _
"#_MIST_#_1850 - 02 - Donald.cbr"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")