import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^#_MIST_#_)(?P<series>[^-]+)(?=\\s-)";
final String string = "#_MIST_#_... Cartoons - 02 - Dieven Cartoons.cbr\n"
+ "#_MIST_#_1850 - 02 - Donald.cbr";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}