$re = '/(?<=^#_MIST_#_)(?P<series>[^-]+)(?=\s-)/m';
$str = '#_MIST_#_... Cartoons - 02 - Dieven Cartoons.cbr
#_MIST_#_1850 - 02 - Donald.cbr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);