use strict;
my $str = '#_MIST_#_... Cartoons - 02 - Dieven Cartoons.cbr
#_MIST_#_1850 - 02 - Donald.cbr';
my $regex = qr/(?<=^#_MIST_#_)(?P<series>[^-]+)(?=\s-)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}