using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=^#_MIST_#_)(?P<series>[^-]+)(?=\s-)";
string input = @"#_MIST_#_... Cartoons - 02 - Dieven Cartoons.cbr
#_MIST_#_1850 - 02 - Donald.cbr";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}