re = /(?<=^#_MIST_#_)(?P<series>[^-]+)(?=\s-)/m
str = '#_MIST_#_... Cartoons - 02 - Dieven Cartoons.cbr
#_MIST_#_1850 - 02 - Donald.cbr'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end