#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((09|\+639)|(|\d{2}|\d{3}))(-|\s)(\d{9}|\d{7})$"
Local $sString = "+639 123456789" & @CRLF & _
"09 123456789" & @CRLF & _
"02 8324545" & @CRLF & _
"034 8324545" & @CRLF & _
"" & @CRLF & _
"+639-123456789" & @CRLF & _
"09-123456789" & @CRLF & _
"02-8324545" & @CRLF & _
"034-8324545" & @CRLF & _
"asd" & @CRLF & _
"12341234" & @CRLF & _
"+63912345" & @CRLF & _
"0913456" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")