use strict;
my $str = '+639 123456789
09 123456789
02 8324545
034 8324545
+639-123456789
09-123456789
02-8324545
034-8324545
asd
12341234
+63912345
0913456
';
my $regex = qr/^((09|\+639)|(|\d{2}|\d{3}))(-|\s)(\d{9}|\d{7})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}