using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((09|\+639)|(|\d{2}|\d{3}))(-|\s)(\d{9}|\d{7})$";
string input = @"+639 123456789
09 123456789
02 8324545
034 8324545
+639-123456789
09-123456789
02-8324545
034-8324545
asd
12341234
+63912345
0913456
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}