import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((09|\\+639)|(|\\d{2}|\\d{3}))(-|\\s)(\\d{9}|\\d{7})$";
final String string = "+639 123456789\n"
+ "09 123456789\n"
+ "02 8324545\n"
+ "034 8324545\n\n"
+ "+639-123456789\n"
+ "09-123456789\n"
+ "02-8324545\n"
+ "034-8324545\n"
+ "asd\n"
+ "12341234\n"
+ "+63912345\n"
+ "0913456\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}