// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^((09|\+639)|(|\d{2}|\d{3}))(-|\s)(\d{9}|\d{7})$").unwrap();
let string = "+639 123456789
09 123456789
02 8324545
034 8324545
+639-123456789
09-123456789
02-8324545
034-8324545
asd
12341234
+63912345
0913456
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}