#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:\/[a-z0-9](?:[^\/ _"’\n.-]|\.(?=(?:jpe?g|gif|png|html?)$)|\-(?!$))+)+$"
Local $sString = "Excepted" & @CRLF & _
"" & @CRLF & _
"/test/test.html" & @CRLF & _
"/test/test" & @CRLF & _
"/test/test-test.htm" & @CRLF & _
"/test/test-test" & @CRLF & _
"/test/test123.htm" & @CRLF & _
"/test/test123" & @CRLF & _
"" & @CRLF & _
"Rejected" & @CRLF & _
"" & @CRLF & _
"/test/test-" & @CRLF & _
"/test/test.htmaaaaaaa" & @CRLF & _
"/test/test." & @CRLF & _
"/test/.hhh" & @CRLF & _
"/tes t" & @CRLF & _
"/tes_t" & @CRLF & _
"/tes"t" & @CRLF & _
"/tes’t" & @CRLF & _
"/-test (cannot start with any thing else other than letters/numbers"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")