re = /^(?:\/[a-z0-9](?:[^\/ _"’\n.-]|\.(?=(?:jpe?g|gif|png|html?)$)|\-(?!$))+)+$/mi
str = 'Excepted
/test/test.html
/test/test
/test/test-test.htm
/test/test-test
/test/test123.htm
/test/test123
Rejected
/test/test-
/test/test.htmaaaaaaa
/test/test.
/test/.hhh
/tes t
/tes_t
/tes"t
/tes’t
/-test (cannot start with any thing else other than letters/numbers'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end