$re = '/^(?:\/[a-z0-9](?:[^\/ _"’\n.-]|\.(?=(?:jpe?g|gif|png|html?)$)|\-(?!$))+)+$/mi';
$str = 'Excepted
/test/test.html
/test/test
/test/test-test.htm
/test/test-test
/test/test123.htm
/test/test123
Rejected
/test/test-
/test/test.htmaaaaaaa
/test/test.
/test/.hhh
/tes t
/tes_t
/tes"t
/tes’t
/-test (cannot start with any thing else other than letters/numbers';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);