const regex = /^(?:\/[a-z0-9](?:[^\/ _"’\n.-]|\.(?=(?:jpe?g|gif|png|html?)$)|\-(?!$))+)+$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\\/[a-z0-9](?:[^\\\/ _"’\\n.-]|\\.(?=(?:jpe?g|gif|png|html?)$)|\\-(?!$))+)+$', 'gmi')
const str = `Excepted
/test/test.html
/test/test
/test/test-test.htm
/test/test-test
/test/test123.htm
/test/test123
Rejected
/test/test-
/test/test.htmaaaaaaa
/test/test.
/test/.hhh
/tes t
/tes_t
/tes"t
/tes’t
/-test (cannot start with any thing else other than letters/numbers`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}