use strict;
my $str = 'Excepted
/test/test.html
/test/test
/test/test-test.htm
/test/test-test
/test/test123.htm
/test/test123
Rejected
/test/test-
/test/test.htmaaaaaaa
/test/test.
/test/.hhh
/tes t
/tes_t
/tes"t
/tes’t
/-test (cannot start with any thing else other than letters/numbers';
my $regex = qr/^(?:\/[a-z0-9](?:[^\/ _"’\n.-]|\.(?=(?:jpe?g|gif|png|html?)$)|\-(?!$))+)+$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}