import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\/[a-z0-9](?:[^\\/ _\"’\\n.-]|\\.(?=(?:jpe?g|gif|png|html?)$)|\\-(?!$))+)+$";
final String string = "Excepted\n\n"
+ "/test/test.html\n"
+ "/test/test\n"
+ "/test/test-test.htm\n"
+ "/test/test-test\n"
+ "/test/test123.htm\n"
+ "/test/test123\n\n"
+ "Rejected\n\n"
+ "/test/test-\n"
+ "/test/test.htmaaaaaaa\n"
+ "/test/test.\n"
+ "/test/.hhh\n"
+ "/tes t\n"
+ "/tes_t\n"
+ "/tes\"t\n"
+ "/tes’t\n"
+ "/-test (cannot start with any thing else other than letters/numbers";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}