using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[^#]*#([^#]*)#[^#]*#\1.*$";
string substitution = @"";
string input = @"someString#MY_STRING#someString#MY_STRING#someString#
someString#MY_STRING#someString#MY_TRING#someString#";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}