import Foundation
let pattern = ##"^[^#]*#([^#]*)#[^#]*#\1.*$"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = ##"""
someString#MY_STRING#someString#MY_STRING#someString#
someString#MY_STRING#someString#MY_TRING#someString#
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)