$re = '/^[^#]*#([^#]*)#[^#]*#\1.*$/im';
$str = 'someString#MY_STRING#someString#MY_STRING#someString#
someString#MY_STRING#someString#MY_TRING#someString#';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;