import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^#]*#([^#]*)#[^#]*#\\1.*$";
final String string = "someString#MY_STRING#someString#MY_STRING#someString#\n"
+ "someString#MY_STRING#someString#MY_TRING#someString#";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}